p PatchFirst

CVE-2025-71404

CVE-2025-71404 · better-auth before 1.1.16 Reflected XSS via error parameter

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

better-auth versions after v0.0.2 and before 1.1.16 contain a reflected cross-site scripting (XSS) vulnerability on the /api/auth/error page, where the value of the 'error' URL parameter is reflected as HTML without proper neutralization. An attacker who coerces a user into visiting a specially-crafted URL can execute arbitrary JavaScript in the context of the user's browser. The issue is fixed in version 1.1.16.

CVSS 5.1 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • better-auth

    Softwareversionen
    • ≥ 0, < 1.1.16: Betroffen (semver)
    • 1.1.16: Nicht betroffen (semver)

    Auf 1.1.16 aktualisieren

  • better-auth npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.0.2, < 1.1.16

    Auf 1.1.16 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →