CVE-2026-105626
CVE-2026-105626 · Consul vulnerable to a denial of service in HTTP APIs
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an unauthenticated attacker to exhaust memory on a Consul agent. This vulnerability (CVE-2026-105626) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.
CVSS 7.5 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
consul
- Versiones
- ≥ 0.6.0, < 2.1.0: Afectada (semver)
Actualiza a 2.1.0
consul enterprise
- Versiones
- ≥ 0.6.0, < 2.1.0: Afectada; ≥ 1.21.19: No afectada (semver)
Actualiza a 1.21.19
consul Ubuntu:18.04:LTS
- Versiones
- 0.6.4~dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
consul Ubuntu:20.04:LTS
- Versiones
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
consul Ubuntu:22.04:LTS
- Versiones
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada