CVE-2026-105626
CVE-2026-105626 · Consul vulnerable to a denial of service in HTTP APIs
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an unauthenticated attacker to exhaust memory on a Consul agent. This vulnerability (CVE-2026-105626) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.
CVSS 7.5 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
consul
- Versions du logiciel
- ≥ 0.6.0, < 2.1.0: Concernée (semver)
Mettez à jour vers 2.1.0
consul enterprise
- Versions du logiciel
- ≥ 0.6.0, < 2.1.0: Concernée; ≥ 1.21.19: Non concernée (semver)
Mettez à jour vers 1.21.19
consul Ubuntu:18.04:LTS
- Versions du logiciel
- 0.6.4~dfsg-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
consul Ubuntu:20.04:LTS
- Versions du logiciel
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
consul Ubuntu:22.04:LTS
- Versions du logiciel
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié