CVE-2026-105626
CVE-2026-105626 · Consul vulnerable to a denial of service in HTTP APIs
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an unauthenticated attacker to exhaust memory on a Consul agent. This vulnerability (CVE-2026-105626) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.
CVSS 7.5 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
consul
- Softwareversionen
- ≥ 0.6.0, < 2.1.0: Betroffen (semver)
Auf 2.1.0 aktualisieren
consul enterprise
- Softwareversionen
- ≥ 0.6.0, < 2.1.0: Betroffen; ≥ 1.21.19: Nicht betroffen (semver)
Auf 1.21.19 aktualisieren
consul Ubuntu:18.04:LTS
- Softwareversionen
- 0.6.4~dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
consul Ubuntu:20.04:LTS
- Softwareversionen
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
consul Ubuntu:22.04:LTS
- Softwareversionen
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht