CVE-2026-105626
CVE-2026-105626 · Consul vulnerable to a denial of service in HTTP APIs
This page contains facts from public vulnerability sources. Check the original advisory before updating.
HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an unauthenticated attacker to exhaust memory on a Consul agent. This vulnerability (CVE-2026-105626) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.
CVSS 7.5 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
consul
- Versions
- ≥ 0.6.0, < 2.1.0: Affected (semver)
Update to 2.1.0
consul enterprise
- Versions
- ≥ 0.6.0, < 2.1.0: Affected; ≥ 1.21.19: Not affected (semver)
Update to 1.21.19
consul Ubuntu:18.04:LTS
- Versions
- 0.6.4~dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:20.04:LTS
- Versions
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:22.04:LTS
- Versions
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published