p PatchFirst

CVE-2026-105856

CVE-2026-105856 · Payload: SQL injection in SQLite/Postgres

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Payload is a free and open source headless content management system. Prior to 3.90.0 and 4.0.0-canary.34, an attacker with read and create or update access to a collection containing a json field or a blocks field with blocksAsJSON enabled can inject SQL through a crafted field path and operators. Collections without those fields are not affected, and richText fields are not affected. The SQLite packages are fixed in versions 3.90.0 and 4.0.0-canary.34, and the Postgres packages are fixed in version 3.73.0.

CVSS 8.6 · Alta · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • payload

    Versiones
    • >= 3.0.0, < 3.90.0: Afectada
    • >= 4.0.0-canary.0, < 4.0.0-canary.34: Afectada

    Sin corrección publicada

  • db-d1-sqlite

    Versiones
    • >= 3.0.0, < 3.90.0: Afectada
    • >= 4.0.0-canary.0, < 4.0.0-canary.34: Afectada

    Sin corrección publicada

  • db-postgres

    Versiones
    • >= 3.0.0 < 3.73.0: Afectada

    Sin corrección publicada

  • db-sqlite

    Versiones
    • >= 3.0.0, < 3.90.0: Afectada
    • >= 4.0.0-canary.0, < 4.0.0-canary.34: Afectada

    Sin corrección publicada

  • db-vercel-postgres

    Versiones
    • >= 3.0.0 < 3.73.0: Afectada

    Sin corrección publicada

  • @payloadcms/db-sqlite npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.90.0

    Actualiza a 3.90.0

  • @payloadcms/db-d1-sqlite npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.90.0

    Actualiza a 3.90.0

  • @payloadcms/db-postgres npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.73.0

    Actualiza a 3.73.0

  • @payloadcms/db-vercel-postgres npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.73.0

    Actualiza a 3.73.0

  • @payloadcms/db-sqlite npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34

    Actualiza a 4.0.0-canary.34

  • @payloadcms/db-d1-sqlite npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34

    Actualiza a 4.0.0-canary.34

Fuentes originales

Comprueba tu servidor →