CVE-2026-105856
CVE-2026-105856 · Payload: SQL injection in SQLite/Postgres
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Payload is a free and open source headless content management system. Prior to 3.90.0 and 4.0.0-canary.34, an attacker with read and create or update access to a collection containing a json field or a blocks field with blocksAsJSON enabled can inject SQL through a crafted field path and operators. Collections without those fields are not affected, and richText fields are not affected. The SQLite packages are fixed in versions 3.90.0 and 4.0.0-canary.34, and the Postgres packages are fixed in version 3.73.0.
CVSS 8.6 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
payload
- Softwareversionen
- >= 3.0.0, < 3.90.0: Betroffen
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Betroffen
Keine Korrektur veröffentlicht
db-d1-sqlite
- Softwareversionen
- >= 3.0.0, < 3.90.0: Betroffen
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Betroffen
Keine Korrektur veröffentlicht
db-postgres
- Softwareversionen
- >= 3.0.0 < 3.73.0: Betroffen
Keine Korrektur veröffentlicht
db-sqlite
- Softwareversionen
- >= 3.0.0, < 3.90.0: Betroffen
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Betroffen
Keine Korrektur veröffentlicht
db-vercel-postgres
- Softwareversionen
- >= 3.0.0 < 3.73.0: Betroffen
Keine Korrektur veröffentlicht
@payloadcms/db-sqlite npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.90.0
Auf 3.90.0 aktualisieren
@payloadcms/db-d1-sqlite npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.90.0
Auf 3.90.0 aktualisieren
@payloadcms/db-postgres npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.73.0
Auf 3.73.0 aktualisieren
@payloadcms/db-vercel-postgres npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.73.0
Auf 3.73.0 aktualisieren
@payloadcms/db-sqlite npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Auf 4.0.0-canary.34 aktualisieren
@payloadcms/db-d1-sqlite npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Auf 4.0.0-canary.34 aktualisieren