CVE-2026-105856
CVE-2026-105856 · Payload: SQL injection in SQLite/Postgres
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Payload is a free and open source headless content management system. Prior to 3.90.0 and 4.0.0-canary.34, an attacker with read and create or update access to a collection containing a json field or a blocks field with blocksAsJSON enabled can inject SQL through a crafted field path and operators. Collections without those fields are not affected, and richText fields are not affected. The SQLite packages are fixed in versions 3.90.0 and 4.0.0-canary.34, and the Postgres packages are fixed in version 3.73.0.
CVSS 8.6 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
payload
- Versions
- >= 3.0.0, < 3.90.0: Affected
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Affected
No fix published
db-d1-sqlite
- Versions
- >= 3.0.0, < 3.90.0: Affected
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Affected
No fix published
db-postgres
- Versions
- >= 3.0.0 < 3.73.0: Affected
No fix published
db-sqlite
- Versions
- >= 3.0.0, < 3.90.0: Affected
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Affected
No fix published
db-vercel-postgres
- Versions
- >= 3.0.0 < 3.73.0: Affected
No fix published
@payloadcms/db-sqlite npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.90.0
Update to 3.90.0
@payloadcms/db-d1-sqlite npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.90.0
Update to 3.90.0
@payloadcms/db-postgres npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.73.0
Update to 3.73.0
@payloadcms/db-vercel-postgres npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.73.0
Update to 3.73.0
@payloadcms/db-sqlite npm
- Affected ranges
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Update to 4.0.0-canary.34
@payloadcms/db-d1-sqlite npm
- Affected ranges
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Update to 4.0.0-canary.34