CVE-2026-105856
CVE-2026-105856 · Payload: SQL injection in SQLite/Postgres
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Payload is a free and open source headless content management system. Prior to 3.90.0 and 4.0.0-canary.34, an attacker with read and create or update access to a collection containing a json field or a blocks field with blocksAsJSON enabled can inject SQL through a crafted field path and operators. Collections without those fields are not affected, and richText fields are not affected. The SQLite packages are fixed in versions 3.90.0 and 4.0.0-canary.34, and the Postgres packages are fixed in version 3.73.0.
CVSS 8.6 · Élevée · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
payload
- Versions du logiciel
- >= 3.0.0, < 3.90.0: Concernée
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Concernée
Aucun correctif publié
db-d1-sqlite
- Versions du logiciel
- >= 3.0.0, < 3.90.0: Concernée
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Concernée
Aucun correctif publié
db-postgres
- Versions du logiciel
- >= 3.0.0 < 3.73.0: Concernée
Aucun correctif publié
db-sqlite
- Versions du logiciel
- >= 3.0.0, < 3.90.0: Concernée
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Concernée
Aucun correctif publié
db-vercel-postgres
- Versions du logiciel
- >= 3.0.0 < 3.73.0: Concernée
Aucun correctif publié
@payloadcms/db-sqlite npm
- Plages de versions concernées
- SEMVER: ≥ 3.0.0, < 3.90.0
Mettez à jour vers 3.90.0
@payloadcms/db-d1-sqlite npm
- Plages de versions concernées
- SEMVER: ≥ 3.0.0, < 3.90.0
Mettez à jour vers 3.90.0
@payloadcms/db-postgres npm
- Plages de versions concernées
- SEMVER: ≥ 3.0.0, < 3.73.0
Mettez à jour vers 3.73.0
@payloadcms/db-vercel-postgres npm
- Plages de versions concernées
- SEMVER: ≥ 3.0.0, < 3.73.0
Mettez à jour vers 3.73.0
@payloadcms/db-sqlite npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Mettez à jour vers 4.0.0-canary.34
@payloadcms/db-d1-sqlite npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Mettez à jour vers 4.0.0-canary.34