CVE-2026-106456
CVE-2026-106456 · Backstage: Inconsistent credential enforcement for overlapping proxy routes
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
CVSS 4.8 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
backstage
- Versiones
- >= 1.28.0, < 1.55.0: Afectada
Sin corrección publicada
plugin-proxy-backend
- Versiones
- >= 0.5.0, < 0.6.18: Afectada
Sin corrección publicada
@backstage/plugin-proxy-backend npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.5.0, < 0.6.18
Actualiza a 0.6.18