CVE-2026-106456
CVE-2026-106456 · Backstage: Inconsistent credential enforcement for overlapping proxy routes
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
CVSS 4.8 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
backstage
- Softwareversionen
- >= 1.28.0, < 1.55.0: Betroffen
Keine Korrektur veröffentlicht
plugin-proxy-backend
- Softwareversionen
- >= 0.5.0, < 0.6.18: Betroffen
Keine Korrektur veröffentlicht
@backstage/plugin-proxy-backend npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.5.0, < 0.6.18
Auf 0.6.18 aktualisieren