CVE-2026-106456
CVE-2026-106456 · Backstage: Inconsistent credential enforcement for overlapping proxy routes
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
CVSS 4.8 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
backstage
- Versions
- >= 1.28.0, < 1.55.0: Affected
No fix published
plugin-proxy-backend
- Versions
- >= 0.5.0, < 0.6.18: Affected
No fix published
@backstage/plugin-proxy-backend npm
- Affected ranges
- SEMVER: ≥ 0.5.0, < 0.6.18
Update to 0.6.18