CVE-2026-27971
CVE-2026-27971 · Qwik affected by unauthenticated RCE via server$ Deserialization
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
CVSS 9.2 · Crítica · EPSS 5,5% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
qwik
- Versiones
- < 1.19.1: Afectada
Sin corrección publicada
@builder.io/qwik npm
- Intervalos de versiones afectados
- SEMVER: < 1.19.1
Actualiza a 1.19.1