p PatchFirst

CVE-2026-27971

CVE-2026-27971 · Qwik affected by unauthenticated RCE via server$ Deserialization

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

CVSS 9.2 · Critique · EPSS 5,5% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • qwik

    Versions du logiciel
    • < 1.19.1: Concernée

    Aucun correctif publié

  • @builder.io/qwik npm

    Plages de versions concernées
    • SEMVER: < 1.19.1

    Mettez à jour vers 1.19.1

Sources originales

Vérifiez votre serveur →