p PatchFirst

CVE-2026-27971

CVE-2026-27971 · Qwik affected by unauthenticated RCE via server$ Deserialization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

CVSS 9.2 · Kritisch · EPSS 5,5% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • qwik

    Softwareversionen
    • < 1.19.1: Betroffen

    Keine Korrektur veröffentlicht

  • @builder.io/qwik npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.19.1

    Auf 1.19.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →