CVE-2026-27971
CVE-2026-27971 · Qwik affected by unauthenticated RCE via server$ Deserialization
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
CVSS 9.2 · Critical · EPSS 5.5% · Public exploit · Fix available
- Published
- Updated
Stack: node
Affected products and versions
qwik
- Versions
- < 1.19.1: Affected
No fix published
@builder.io/qwik npm
- Affected ranges
- SEMVER: < 1.19.1
Update to 1.19.1