p PatchFirst

CVE-2026-31828

CVE-2026-31828 · Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.

CVSS 6.0 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • parse-server

    Versiones
    • >= 9.0.0 < 9.5.2-alpha.13: Afectada
    • < 8.6.26: Afectada

    Sin corrección publicada

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 9.0.0-alpha.1, < 9.5.2-alpha.13

    Actualiza a 9.5.2-alpha.13

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: < 8.6.26

    Actualiza a 8.6.26

Fuentes originales

Comprueba tu servidor →