CVE-2026-31828
CVE-2026-31828 · Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.
CVSS 6.0 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
parse-server
- Versions
- >= 9.0.0 < 9.5.2-alpha.13: Affected
- < 8.6.26: Affected
No fix published
parse-server npm
- Affected ranges
- SEMVER: ≥ 9.0.0-alpha.1, < 9.5.2-alpha.13
Update to 9.5.2-alpha.13
parse-server npm
- Affected ranges
- SEMVER: < 8.6.26
Update to 8.6.26