CVE-2026-31828
CVE-2026-31828 · Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.
CVSS 6.0 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
parse-server
- Versions du logiciel
- >= 9.0.0 < 9.5.2-alpha.13: Concernée
- < 8.6.26: Concernée
Aucun correctif publié
parse-server npm
- Plages de versions concernées
- SEMVER: ≥ 9.0.0-alpha.1, < 9.5.2-alpha.13
Mettez à jour vers 9.5.2-alpha.13
parse-server npm
- Plages de versions concernées
- SEMVER: < 8.6.26
Mettez à jour vers 8.6.26