p PatchFirst

CVE-2026-31828

CVE-2026-31828 · Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.

CVSS 6.0 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • parse-server

    Softwareversionen
    • >= 9.0.0 < 9.5.2-alpha.13: Betroffen
    • < 8.6.26: Betroffen

    Keine Korrektur veröffentlicht

  • parse-server npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 9.0.0-alpha.1, < 9.5.2-alpha.13

    Auf 9.5.2-alpha.13 aktualisieren

  • parse-server npm

    Betroffene Versionsbereiche
    • SEMVER: < 8.6.26

    Auf 8.6.26 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →