p PatchFirst

CVE-2026-33804

CVE-2026-33804 · @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

CVSS 7.4 · Alta · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • @fastify/middie

    Versiones
    • ≥ 0, < 9.3.2: Afectada (semver)
    • 9.3.2: No afectada (semver)

    Actualiza a 9.3.2

  • @fastify/middie npm

    Intervalos de versiones afectados
    • SEMVER: < 9.3.2

    Actualiza a 9.3.2

Fuentes originales

Comprueba tu servidor →