p PatchFirst

CVE-2026-33804

CVE-2026-33804 · @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

This page contains facts from public vulnerability sources. Check the original advisory before updating.

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

CVSS 7.4 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • @fastify/middie

    Versions
    • ≥ 0, < 9.3.2: Affected (semver)
    • 9.3.2: Not affected (semver)

    Update to 9.3.2

  • @fastify/middie npm

    Affected ranges
    • SEMVER: < 9.3.2

    Update to 9.3.2

Original sources

Check your server →