p PatchFirst

CVE-2026-33804

CVE-2026-33804 · @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

CVSS 7.4 · Élevée · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • @fastify/middie

    Versions du logiciel
    • ≥ 0, < 9.3.2: Concernée (semver)
    • 9.3.2: Non concernée (semver)

    Mettez à jour vers 9.3.2

  • @fastify/middie npm

    Plages de versions concernées
    • SEMVER: < 9.3.2

    Mettez à jour vers 9.3.2

Sources originales

Vérifiez votre serveur →