p PatchFirst

CVE-2026-33858

CVE-2026-33858 · Apache Airflow: Unsafe Deserialization via Legacy Serialization Keys (__type/__var) Bypass in XCom API

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.

CVSS 8.8 · Alta · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • apache airflow

    Versiones
    • ≥ 3.1.8, < 3.2.0: Afectada (semver)

    Actualiza a 3.2.0

  • apache-airflow PyPI

    Versiones
    • 3.1.8
    • 3.2.0b1
    • 3.2.0b2
    • 3.2.0rc1
    • 3.2.0rc2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 3.1.8, < 3.2.0

    Actualiza a 3.2.0

Fuentes originales

Comprueba tu servidor →