p PatchFirst

CVE-2026-33858

CVE-2026-33858 · Apache Airflow: Unsafe Deserialization via Legacy Serialization Keys (__type/__var) Bypass in XCom API

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.

CVSS 8.8 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • apache airflow

    Softwareversionen
    • ≥ 3.1.8, < 3.2.0: Betroffen (semver)

    Auf 3.2.0 aktualisieren

  • apache-airflow PyPI

    Softwareversionen
    • 3.1.8
    • 3.2.0b1
    • 3.2.0b2
    • 3.2.0rc1
    • 3.2.0rc2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.1.8, < 3.2.0

    Auf 3.2.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →