CVE-2026-33858
CVE-2026-33858 · Apache Airflow: Unsafe Deserialization via Legacy Serialization Keys (__type/__var) Bypass in XCom API
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.
CVSS 8.8 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- ≥ 3.1.8, < 3.2.0: Affected (semver)
Update to 3.2.0
apache-airflow PyPI
- Versions
- 3.1.8
- 3.2.0b1
- 3.2.0b2
- 3.2.0rc1
- 3.2.0rc2
- Affected ranges
- ECOSYSTEM: ≥ 3.1.8, < 3.2.0
Update to 3.2.0