p PatchFirst

CVE-2026-33858

CVE-2026-33858 · Apache Airflow: Unsafe Deserialization via Legacy Serialization Keys (__type/__var) Bypass in XCom API

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.

CVSS 8.8 · Élevée · EPSS 0,6% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • apache airflow

    Versions du logiciel
    • ≥ 3.1.8, < 3.2.0: Concernée (semver)

    Mettez à jour vers 3.2.0

  • apache-airflow PyPI

    Versions du logiciel
    • 3.1.8
    • 3.2.0b1
    • 3.2.0b2
    • 3.2.0rc1
    • 3.2.0rc2
    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.1.8, < 3.2.0

    Mettez à jour vers 3.2.0

Sources originales

Vérifiez votre serveur →