p PatchFirst

CVE-2026-42311

CVE-2026-42311 · Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.

CVSS 8.6 · Alta · EPSS 0,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • pillow

    Versiones
    • >= 10.3.0, < 12.2.0: Afectada

    Sin corrección publicada

  • pillow Debian:13

    Versiones
    • 11.1.0-5
    • 11.1.0-5+deb13u1
    • 11.1.0-5+deb13u2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 11.1.0-5+deb13u3

    Actualiza a 11.1.0-5+deb13u3

  • pillow Debian:14

    Versiones
    • 11.1.0-5
    • 11.2.1-1
    • 11.3.0-1
    • 12.0.0-1
    • 12.1.0-1
    • 12.1.1-1
    • 12.1.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 12.2.0-1

    Actualiza a 12.2.0-1

  • pillow PyPI

    Versiones
    • 10.3.0
    • 10.4.0
    • 11.0.0
    • 11.1.0
    • 11.2.1
    • 11.3.0
    • 12.0.0
    • 12.1.0
    • 12.1.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 10.3.0, < 12.2.0

    Actualiza a 12.2.0

  • pillow-python2 Ubuntu:Pro:20.04:LTS

    Versiones
    • 6.2.1-3~build1
    • 6.2.1-3
    • 6.2.1-3ubuntu0.1~esm1
    • 6.2.1-3ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pillow Ubuntu:25.10

    Versiones
    • 11.1.0-5build1
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu1.1
    • 11.3.0-1ubuntu1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 11.3.0-1ubuntu1.3

    Actualiza a 11.3.0-1ubuntu1.3

  • pillow Ubuntu:26.04:LTS

    Versiones
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu2
    • 12.0.0-1ubuntu1
    • 12.1.1-1ubuntu1
    • 12.1.1-2ubuntu1
    • 12.1.1-2ubuntu1.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 12.1.1-2ubuntu1.2

    Actualiza a 12.1.1-2ubuntu1.2

Fuentes originales

Comprueba tu servidor →