p PatchFirst

CVE-2026-42311

CVE-2026-42311 · Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.

CVSS 8.6 · Élevée · EPSS 0,1% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · python

Produits et versions concernés

  • pillow

    Versions du logiciel
    • >= 10.3.0, < 12.2.0: Concernée

    Aucun correctif publié

  • pillow Debian:13

    Versions du logiciel
    • 11.1.0-5
    • 11.1.0-5+deb13u1
    • 11.1.0-5+deb13u2
    Plages de versions concernées
    • ECOSYSTEM: < 11.1.0-5+deb13u3

    Mettez à jour vers 11.1.0-5+deb13u3

  • pillow Debian:14

    Versions du logiciel
    • 11.1.0-5
    • 11.2.1-1
    • 11.3.0-1
    • 12.0.0-1
    • 12.1.0-1
    • 12.1.1-1
    • 12.1.1-2
    Plages de versions concernées
    • ECOSYSTEM: < 12.2.0-1

    Mettez à jour vers 12.2.0-1

  • pillow PyPI

    Versions du logiciel
    • 10.3.0
    • 10.4.0
    • 11.0.0
    • 11.1.0
    • 11.2.1
    • 11.3.0
    • 12.0.0
    • 12.1.0
    • 12.1.1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 10.3.0, < 12.2.0

    Mettez à jour vers 12.2.0

  • pillow-python2 Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 6.2.1-3~build1
    • 6.2.1-3
    • 6.2.1-3ubuntu0.1~esm1
    • 6.2.1-3ubuntu0.1~esm2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • pillow Ubuntu:25.10

    Versions du logiciel
    • 11.1.0-5build1
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu1.1
    • 11.3.0-1ubuntu1.2
    Plages de versions concernées
    • ECOSYSTEM: < 11.3.0-1ubuntu1.3

    Mettez à jour vers 11.3.0-1ubuntu1.3

  • pillow Ubuntu:26.04:LTS

    Versions du logiciel
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu2
    • 12.0.0-1ubuntu1
    • 12.1.1-1ubuntu1
    • 12.1.1-2ubuntu1
    • 12.1.1-2ubuntu1.1
    Plages de versions concernées
    • ECOSYSTEM: < 12.1.1-2ubuntu1.2

    Mettez à jour vers 12.1.1-2ubuntu1.2

Sources originales

Vérifiez votre serveur →