p PatchFirst

CVE-2026-42311

CVE-2026-42311 · Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.

CVSS 8.6 · Hoch · EPSS 0,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • pillow

    Softwareversionen
    • >= 10.3.0, < 12.2.0: Betroffen

    Keine Korrektur veröffentlicht

  • pillow Debian:13

    Softwareversionen
    • 11.1.0-5
    • 11.1.0-5+deb13u1
    • 11.1.0-5+deb13u2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 11.1.0-5+deb13u3

    Auf 11.1.0-5+deb13u3 aktualisieren

  • pillow Debian:14

    Softwareversionen
    • 11.1.0-5
    • 11.2.1-1
    • 11.3.0-1
    • 12.0.0-1
    • 12.1.0-1
    • 12.1.1-1
    • 12.1.1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 12.2.0-1

    Auf 12.2.0-1 aktualisieren

  • pillow PyPI

    Softwareversionen
    • 10.3.0
    • 10.4.0
    • 11.0.0
    • 11.1.0
    • 11.2.1
    • 11.3.0
    • 12.0.0
    • 12.1.0
    • 12.1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 10.3.0, < 12.2.0

    Auf 12.2.0 aktualisieren

  • pillow-python2 Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 6.2.1-3~build1
    • 6.2.1-3
    • 6.2.1-3ubuntu0.1~esm1
    • 6.2.1-3ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pillow Ubuntu:25.10

    Softwareversionen
    • 11.1.0-5build1
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu1.1
    • 11.3.0-1ubuntu1.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 11.3.0-1ubuntu1.3

    Auf 11.3.0-1ubuntu1.3 aktualisieren

  • pillow Ubuntu:26.04:LTS

    Softwareversionen
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu2
    • 12.0.0-1ubuntu1
    • 12.1.1-1ubuntu1
    • 12.1.1-2ubuntu1
    • 12.1.1-2ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 12.1.1-2ubuntu1.2

    Auf 12.1.1-2ubuntu1.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →