p PatchFirst

CVE-2026-42311

CVE-2026-42311 · Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.

CVSS 8.6 · High · EPSS 0.1% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • pillow

    Versions
    • >= 10.3.0, < 12.2.0: Affected

    No fix published

  • pillow Debian:13

    Versions
    • 11.1.0-5
    • 11.1.0-5+deb13u1
    • 11.1.0-5+deb13u2
    Affected ranges
    • ECOSYSTEM: < 11.1.0-5+deb13u3

    Update to 11.1.0-5+deb13u3

  • pillow Debian:14

    Versions
    • 11.1.0-5
    • 11.2.1-1
    • 11.3.0-1
    • 12.0.0-1
    • 12.1.0-1
    • 12.1.1-1
    • 12.1.1-2
    Affected ranges
    • ECOSYSTEM: < 12.2.0-1

    Update to 12.2.0-1

  • pillow PyPI

    Versions
    • 10.3.0
    • 10.4.0
    • 11.0.0
    • 11.1.0
    • 11.2.1
    • 11.3.0
    • 12.0.0
    • 12.1.0
    • 12.1.1
    Affected ranges
    • ECOSYSTEM: ≥ 10.3.0, < 12.2.0

    Update to 12.2.0

  • pillow-python2 Ubuntu:Pro:20.04:LTS

    Versions
    • 6.2.1-3~build1
    • 6.2.1-3
    • 6.2.1-3ubuntu0.1~esm1
    • 6.2.1-3ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • pillow Ubuntu:25.10

    Versions
    • 11.1.0-5build1
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu1.1
    • 11.3.0-1ubuntu1.2
    Affected ranges
    • ECOSYSTEM: < 11.3.0-1ubuntu1.3

    Update to 11.3.0-1ubuntu1.3

  • pillow Ubuntu:26.04:LTS

    Versions
    • 11.3.0-1ubuntu1
    • 11.3.0-1ubuntu2
    • 12.0.0-1ubuntu1
    • 12.1.1-1ubuntu1
    • 12.1.1-2ubuntu1
    • 12.1.1-2ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 12.1.1-2ubuntu1.2

    Update to 12.1.1-2ubuntu1.2

Original sources

Check your server →