CVE-2026-67327
CVE-2026-67327 · better-auth before 1.6.22 Account Takeover via Magic-Link Email-OTP
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/password registration is enabled. An attacker registers an account with the victim's email address and an attacker-chosen password; the account remains unverified. When the legitimate owner later signs in via the magic-link or email-OTP passwordless flow, the account is marked verified without removing the pre-existing password or revoking existing sessions, so the attacker's password remains valid, granting persistent access to the victim's account. Fixed in 1.6.22 and 1.7.0-beta.10.
CVSS 8.7 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
better-auth
- Versiones
- ≥ 1.1.3, < 1.6.22: Afectada (semver)
- 1.6.22: No afectada (semver)
Actualiza a 1.6.22
better-auth
- Versiones
- ≥ 1.7.0-beta.0, < 1.7.0-beta.10: Afectada (semver)
- 1.7.0-beta.10: No afectada (semver)
Actualiza a 1.7.0-beta.10
better-auth npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.1.3, < 1.6.22
Actualiza a 1.6.22
better-auth npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.7.0-beta.0, < 1.7.0-beta.10
Actualiza a 1.7.0-beta.10