CVE-2026-67327
CVE-2026-67327 · better-auth before 1.6.22 Account Takeover via Magic-Link Email-OTP
This page contains facts from public vulnerability sources. Check the original advisory before updating.
better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/password registration is enabled. An attacker registers an account with the victim's email address and an attacker-chosen password; the account remains unverified. When the legitimate owner later signs in via the magic-link or email-OTP passwordless flow, the account is marked verified without removing the pre-existing password or revoking existing sessions, so the attacker's password remains valid, granting persistent access to the victim's account. Fixed in 1.6.22 and 1.7.0-beta.10.
CVSS 8.7 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
better-auth
- Versions
- ≥ 1.1.3, < 1.6.22: Affected (semver)
- 1.6.22: Not affected (semver)
Update to 1.6.22
better-auth
- Versions
- ≥ 1.7.0-beta.0, < 1.7.0-beta.10: Affected (semver)
- 1.7.0-beta.10: Not affected (semver)
Update to 1.7.0-beta.10
better-auth npm
- Affected ranges
- SEMVER: ≥ 1.1.3, < 1.6.22
Update to 1.6.22
better-auth npm
- Affected ranges
- SEMVER: ≥ 1.7.0-beta.0, < 1.7.0-beta.10
Update to 1.7.0-beta.10