CVE-2026-67327
CVE-2026-67327 · better-auth before 1.6.22 Account Takeover via Magic-Link Email-OTP
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/password registration is enabled. An attacker registers an account with the victim's email address and an attacker-chosen password; the account remains unverified. When the legitimate owner later signs in via the magic-link or email-OTP passwordless flow, the account is marked verified without removing the pre-existing password or revoking existing sessions, so the attacker's password remains valid, granting persistent access to the victim's account. Fixed in 1.6.22 and 1.7.0-beta.10.
CVSS 8.7 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
better-auth
- Softwareversionen
- ≥ 1.1.3, < 1.6.22: Betroffen (semver)
- 1.6.22: Nicht betroffen (semver)
Auf 1.6.22 aktualisieren
better-auth
- Softwareversionen
- ≥ 1.7.0-beta.0, < 1.7.0-beta.10: Betroffen (semver)
- 1.7.0-beta.10: Nicht betroffen (semver)
Auf 1.7.0-beta.10 aktualisieren
better-auth npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.1.3, < 1.6.22
Auf 1.6.22 aktualisieren
better-auth npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 1.7.0-beta.0, < 1.7.0-beta.10
Auf 1.7.0-beta.10 aktualisieren