CVE-2026-67327
CVE-2026-67327 · better-auth before 1.6.22 Account Takeover via Magic-Link Email-OTP
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/password registration is enabled. An attacker registers an account with the victim's email address and an attacker-chosen password; the account remains unverified. When the legitimate owner later signs in via the magic-link or email-OTP passwordless flow, the account is marked verified without removing the pre-existing password or revoking existing sessions, so the attacker's password remains valid, granting persistent access to the victim's account. Fixed in 1.6.22 and 1.7.0-beta.10.
CVSS 8.7 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
better-auth
- Versions du logiciel
- ≥ 1.1.3, < 1.6.22: Concernée (semver)
- 1.6.22: Non concernée (semver)
Mettez à jour vers 1.6.22
better-auth
- Versions du logiciel
- ≥ 1.7.0-beta.0, < 1.7.0-beta.10: Concernée (semver)
- 1.7.0-beta.10: Non concernée (semver)
Mettez à jour vers 1.7.0-beta.10
better-auth npm
- Plages de versions concernées
- SEMVER: ≥ 1.1.3, < 1.6.22
Mettez à jour vers 1.6.22
better-auth npm
- Plages de versions concernées
- SEMVER: ≥ 1.7.0-beta.0, < 1.7.0-beta.10
Mettez à jour vers 1.7.0-beta.10