p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de @aws/lsp-codewhisperer

Vulnerabilidades publicadas para @aws/lsp-codewhisperer en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2026-12958

    Alta · CVSS 8.5EPSS 0,19%Corrección disponible

    Arbitrary file write in Language Servers for AWS

    Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.

    • Actualiza a 0.0.117
    Publicación Actualización
  2. CVE-2026-12957

    Alta · CVSS 8.5EPSS 0,23%Corrección disponible

    Arbitrary Code Execution in Language Servers for AWS

    Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

    • Actualiza a 0.0.113
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →