p PatchFirst

PatchFirst · Latest vulnerabilities

@aws/lsp-codewhisperer vulnerabilities

Vulnerabilities published for @aws/lsp-codewhisperer in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-12958

    High · CVSS 8.5EPSS 0.19%Fix available

    Arbitrary file write in Language Servers for AWS

    Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.

    • Update to 0.0.117
    Published Updated
  2. CVE-2026-12957

    High · CVSS 8.5EPSS 0.23%Fix available

    Arbitrary Code Execution in Language Servers for AWS

    Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

    • Update to 0.0.113
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →