p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de validator

Vulnerabilidades publicadas para validator en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 10

  1. CVE-2025-12758

    Alta · CVSS 8.7EPSS 0,55%Corrección disponible

    CVE-2025-12758

    Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering of One or More Instances of Special Elements in the isLength() function that does not take into account Unicode variation selectors (\uFE0F, \uFE0E) appearing in a sequence which lead to improper string length calculation. This can lead to an application using isLength for input validation accepting strings significantly longer than intended, resulting in issues like data truncation in databases, buffer overflows in other system components, or denial-of-service.

    • Actualiza a 13.15.22
    Publicación Actualización
  2. CVE-2025-56200

    Media · CVSS 6.1EPSS 0,32%Corrección disponible

    CVE-2025-56200

    A URL validation bypass vulnerability exists in validator.js through version 13.15.15. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.

    • Actualiza a 13.15.20
    Publicación Actualización
  3. GHSA-xx4c-jj58-r7x6

    Media · CVSS 5.3Corrección disponible

    Inefficient Regular Expression Complexity in Validator.js

    ### Impact Versions of `validator` prior to 13.7.0 are affected by an inefficient Regular Expression complexity when using the `rtrim` and `trim` sanitizers. ### Patches The problem has been patched in validator 13.7.0

    • Actualiza a 13.7.0
    Publicación Actualización
  4. CVE-2014-8882

    Alta · CVSS 7.5Corrección disponible

    Regular Expression Denial of Service in validator

    Versions of `validator` prior to 3.22.1 are affected by a regular expression denial of service vulnerability in the `isURL` method. ## Recommendation Update to version 3.22.1 or later.

    • Actualiza a 3.22.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →