p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de validator

Vulnérabilité publiée pour validator au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 10

  1. CVE-2025-12758

    Élevée · CVSS 8.7EPSS 0,55%Correctif disponible

    CVE-2025-12758

    Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering of One or More Instances of Special Elements in the isLength() function that does not take into account Unicode variation selectors (\uFE0F, \uFE0E) appearing in a sequence which lead to improper string length calculation. This can lead to an application using isLength for input validation accepting strings significantly longer than intended, resulting in issues like data truncation in databases, buffer overflows in other system components, or denial-of-service.

    • Mettez à jour vers 13.15.22
    Publication Mise à jour
  2. CVE-2025-56200

    Moyenne · CVSS 6.1EPSS 0,32%Correctif disponible

    CVE-2025-56200

    A URL validation bypass vulnerability exists in validator.js through version 13.15.15. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.

    • Mettez à jour vers 13.15.20
    Publication Mise à jour
  3. GHSA-xx4c-jj58-r7x6

    Moyenne · CVSS 5.3Correctif disponible

    Inefficient Regular Expression Complexity in Validator.js

    ### Impact Versions of `validator` prior to 13.7.0 are affected by an inefficient Regular Expression complexity when using the `rtrim` and `trim` sanitizers. ### Patches The problem has been patched in validator 13.7.0

    • Mettez à jour vers 13.7.0
    Publication Mise à jour
  4. CVE-2014-8882

    Élevée · CVSS 7.5Correctif disponible

    Regular Expression Denial of Service in validator

    Versions of `validator` prior to 3.22.1 are affected by a regular expression denial of service vulnerability in the `isURL` method. ## Recommendation Update to version 3.22.1 or later.

    • Mettez à jour vers 3.22.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →