p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in validator

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für validator: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 10

  1. CVE-2025-12758

    Hoch · CVSS 8.7EPSS 0,55%Korrektur verfügbar

    CVE-2025-12758

    Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering of One or More Instances of Special Elements in the isLength() function that does not take into account Unicode variation selectors (\uFE0F, \uFE0E) appearing in a sequence which lead to improper string length calculation. This can lead to an application using isLength for input validation accepting strings significantly longer than intended, resulting in issues like data truncation in databases, buffer overflows in other system components, or denial-of-service.

    • Auf 13.15.22 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-56200

    Mittel · CVSS 6.1EPSS 0,32%Korrektur verfügbar

    CVE-2025-56200

    A URL validation bypass vulnerability exists in validator.js through version 13.15.15. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.

    • Auf 13.15.20 aktualisieren
    Veröffentlicht Aktualisiert
  3. GHSA-xx4c-jj58-r7x6

    Mittel · CVSS 5.3Korrektur verfügbar

    Inefficient Regular Expression Complexity in Validator.js

    ### Impact Versions of `validator` prior to 13.7.0 are affected by an inefficient Regular Expression complexity when using the `rtrim` and `trim` sanitizers. ### Patches The problem has been patched in validator 13.7.0

    • Auf 13.7.0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →