p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de rails · Página 3

Vulnerabilidades publicadas para rails en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 58

  1. CVE-2021-22903

    Media · CVSS 6.1EPSS 1,23%Sin corrección publicada

    CVE-2021-22903

    The actionpack ruby gem before 6.1.3.2 suffers from a possible open redirect vulnerability. Specially crafted Host headers in combination with certain "allowed host" formats can cause the Host Authorization middleware in Action Pack to redirect users to a malicious website. This is similar to CVE-2021-22881. Strings in config.hosts that do not have a leading dot are converted to regular expressions without proper escaping. This causes, for example, `config.hosts << "sub.example.com"` to permit a request with a Host header value of `sub-example.com`.

    Publicación Actualización
  2. CVE-2021-22902

    Alta · CVSS 7.5EPSS 2,87%Sin corrección publicada

    CVE-2021-22902

    The actionpack ruby gem (a framework for handling and responding to web requests in Rails) before 6.0.3.7, 6.1.3.2 suffers from a possible denial of service vulnerability in the Mime type parser of Action Dispatch. Carefully crafted Accept headers can cause the mime type parser in Action Dispatch to do catastrophic backtracking in the regular expression engine.

    Publicación Actualización
  3. CVE-2021-22881

    Media · CVSS 6.1EPSS 87,3%Código de explotación públicoSin corrección publicada

    CVE-2021-22881

    The Host Authorization middleware in Action Pack before 6.1.2.1, 6.0.3.5 suffers from an open redirect vulnerability. Specially crafted `Host` headers in combination with certain "allowed host" formats can cause the Host Authorization middleware in Action Pack to redirect users to a malicious website. Impacted applications will have allowed hosts with a leading dot. When an allowed host contains a leading dot, a specially crafted `Host` header can be used to redirect to a malicious website.

    Publicación Actualización
  4. CVE-2021-22880

    Alta · CVSS 7.5EPSS 4,43%Código de explotación públicoSin corrección publicada

    CVE-2021-22880

    The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

    Publicación Actualización
  5. CVE-2020-15169

    Media · CVSS 5.4EPSS 2,37%Sin corrección publicada

    XSS in Action View

    In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.

    Publicación Actualización
  6. CVE-2020-5267

    Media · CVSS 4EPSS 1,52%Sin corrección publicada

    Possible XSS vulnerability in ActionView

    In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

    Publicación Actualización
  7. CVE-2019-5418

    Alta · CVSS 7.5EPSS 98,51%En el catálogo KEVCódigo de explotación públicoCorrección disponible

    CVE-2019-5418

    There is a File Content Disclosure vulnerability in Action View <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 and v3 where specially crafted accept headers can cause contents of arbitrary files on the target system's filesystem to be exposed.

    • Actualiza a 2:4.2.10-0ubuntu4+esm2
    Publicación Actualización
  8. CVE-2018-16476

    Alta · CVSS 7.5EPSS 2,86%Sin corrección publicada

    CVE-2018-16476

    A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →