p PatchFirst

ALPINE-CVE-2026-28780

ALPINE-CVE-2026-28780

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

CVSS 9.8 · Critique · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • apache2 Alpine:v3.20

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.67-r0

    Mettez à jour vers 2.4.67-r0

  • apache2 Alpine:v3.21

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.67-r0

    Mettez à jour vers 2.4.67-r0

  • apache2 Alpine:v3.22

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.67-r0

    Mettez à jour vers 2.4.67-r0

  • apache2 Alpine:v3.23

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.67-r0

    Mettez à jour vers 2.4.67-r0

  • apache2 Alpine:v3.24

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.67-r0

    Mettez à jour vers 2.4.67-r0

Sources originales

Vérifiez votre serveur →