ALPINE-CVE-2026-28780
ALPINE-CVE-2026-28780
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.67-r0
Update to 2.4.67-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.67-r0
Update to 2.4.67-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.67-r0
Update to 2.4.67-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.67-r0
Update to 2.4.67-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.67-r0
Update to 2.4.67-r0