CVE-2018-1000656
CVE-2018-1000656
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.
CVSS 8.7 · Élevée · EPSS 3,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
flask Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.0.2-1
Mettez à jour vers 1.0.2-1
flask Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.0.2-1
Mettez à jour vers 1.0.2-1
flask Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.0.2-1
Mettez à jour vers 1.0.2-1
flask PyPI
- Versions du logiciel
- 0.1
- 0.10
- 0.10.1
- 0.11
- 0.11.1
- 0.12
- 0.12.1
- 0.12.2
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.5
- 0.5.1
- 0.5.2
- 0.6
- 0.6.1
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.9
- Plages de versions concernées
- ECOSYSTEM: < 0.12.3
Mettez à jour vers 0.12.3
flask Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 0.10.1-2
- 0.10.1-2build1
- Plages de versions concernées
- ECOSYSTEM: < 0.10.1-2ubuntu0.1~esm1
Mettez à jour vers 0.10.1-2ubuntu0.1~esm1
flask Ubuntu:16.04:LTS
- Versions du logiciel
- 0.10.1-2build2
- Plages de versions concernées
- ECOSYSTEM: < 0.10.1-2ubuntu0.1
Mettez à jour vers 0.10.1-2ubuntu0.1
flask Ubuntu:18.04:LTS
- Versions du logiciel
- 0.12.2-2
- 0.12.2-3
- Plages de versions concernées
- ECOSYSTEM: < 0.12.2-3ubuntu0.1
Mettez à jour vers 0.12.2-3ubuntu0.1