CVE-2018-1000656
CVE-2018-1000656
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.
CVSS 8.7 · Alta · EPSS 3,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
flask Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.2-1
Actualiza a 1.0.2-1
flask Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.2-1
Actualiza a 1.0.2-1
flask Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.2-1
Actualiza a 1.0.2-1
flask PyPI
- Versiones
- 0.1
- 0.10
- 0.10.1
- 0.11
- 0.11.1
- 0.12
- 0.12.1
- 0.12.2
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.5
- 0.5.1
- 0.5.2
- 0.6
- 0.6.1
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.12.3
Actualiza a 0.12.3
flask Ubuntu:Pro:14.04:LTS
- Versiones
- 0.10.1-2
- 0.10.1-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.10.1-2ubuntu0.1~esm1
Actualiza a 0.10.1-2ubuntu0.1~esm1
flask Ubuntu:16.04:LTS
- Versiones
- 0.10.1-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.10.1-2ubuntu0.1
Actualiza a 0.10.1-2ubuntu0.1
flask Ubuntu:18.04:LTS
- Versiones
- 0.12.2-2
- 0.12.2-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.12.2-3ubuntu0.1
Actualiza a 0.12.2-3ubuntu0.1