p PatchFirst

CVE-2018-1000656

CVE-2018-1000656

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.

CVSS 8.7 · High · EPSS 3.9% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • flask Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.2-1

    Update to 1.0.2-1

  • flask Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.2-1

    Update to 1.0.2-1

  • flask Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.2-1

    Update to 1.0.2-1

  • flask PyPI

    Versions
    • 0.1
    • 0.10
    • 0.10.1
    • 0.11
    • 0.11.1
    • 0.12
    • 0.12.1
    • 0.12.2
    • 0.2
    • 0.3
    • 0.3.1
    • 0.4
    • 0.5
    • 0.5.1
    • 0.5.2
    • 0.6
    • 0.6.1
    • 0.7
    • 0.7.1
    • 0.7.2
    • 0.8
    • 0.8.1
    • 0.9
    Affected ranges
    • ECOSYSTEM: < 0.12.3

    Update to 0.12.3

  • flask Ubuntu:Pro:14.04:LTS

    Versions
    • 0.10.1-2
    • 0.10.1-2build1
    Affected ranges
    • ECOSYSTEM: < 0.10.1-2ubuntu0.1~esm1

    Update to 0.10.1-2ubuntu0.1~esm1

  • flask Ubuntu:16.04:LTS

    Versions
    • 0.10.1-2build2
    Affected ranges
    • ECOSYSTEM: < 0.10.1-2ubuntu0.1

    Update to 0.10.1-2ubuntu0.1

  • flask Ubuntu:18.04:LTS

    Versions
    • 0.12.2-2
    • 0.12.2-3
    Affected ranges
    • ECOSYSTEM: < 0.12.2-3ubuntu0.1

    Update to 0.12.2-3ubuntu0.1

Original sources

Check your server →