p PatchFirst

CVE-2019-3829

CVE-2019-3829

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.

CVSS 5.3 · Moyenne · EPSS 59,0% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • gnutls

    Versions du logiciel
    • fixed in 3.6.7: Concernée
    • affected from 3.5.8: Concernée

    Aucun correctif publié

  • gnutls28 Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 3.6.7-2

    Mettez à jour vers 3.6.7-2

  • gnutls28 Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 3.6.7-2

    Mettez à jour vers 3.6.7-2

  • gnutls28 Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 3.6.7-2

    Mettez à jour vers 3.6.7-2

  • gnutls28 Ubuntu:18.04:LTS

    Versions du logiciel
    • 3.5.8-6ubuntu3
    • 3.5.17-1ubuntu1
    • 3.5.17-1ubuntu3
    • 3.5.18-1ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: < 3.5.18-1ubuntu1.1

    Mettez à jour vers 3.5.18-1ubuntu1.1

Sources originales

Vérifiez votre serveur →