p PatchFirst

CVE-2019-3829

CVE-2019-3829

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.

CVSS 5.3 · Medium · EPSS 59.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gnutls

    Versions
    • fixed in 3.6.7: Affected
    • affected from 3.5.8: Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.6.7-2

    Update to 3.6.7-2

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.6.7-2

    Update to 3.6.7-2

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.6.7-2

    Update to 3.6.7-2

  • gnutls28 Ubuntu:18.04:LTS

    Versions
    • 3.5.8-6ubuntu3
    • 3.5.17-1ubuntu1
    • 3.5.17-1ubuntu3
    • 3.5.18-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 3.5.18-1ubuntu1.1

    Update to 3.5.18-1ubuntu1.1

Original sources

Check your server →