CVE-2019-5421
CVE-2019-5421
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
CVSS 9.8 · Critique · EPSS 1,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
devise ruby gem
- Versions du logiciel
- 4.5.0 and earlier using the lockable module: Concernée
Aucun correctif publié
ruby-devise Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 4.5.0-3
Mettez à jour vers 4.5.0-3
gitlab Ubuntu:16.04:LTS
- Versions du logiciel
- 8.4.3+dfsg-9
- 8.4.3+dfsg-12
- 8.5.8+dfsg-5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-devise Ubuntu:18.04:LTS
- Versions du logiciel
- 4.2.0-1
- 4.3.0-1
- 4.4.3-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-devise Ubuntu:20.04:LTS
- Plages de versions concernées
- ECOSYSTEM: < 4.5.0-3
Mettez à jour vers 4.5.0-3