CVE-2019-5421
CVE-2019-5421
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
CVSS 9.8 · Kritisch · EPSS 1,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
devise ruby gem
- Softwareversionen
- 4.5.0 and earlier using the lockable module: Betroffen
Keine Korrektur veröffentlicht
ruby-devise Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.5.0-3
Auf 4.5.0-3 aktualisieren
gitlab Ubuntu:16.04:LTS
- Softwareversionen
- 8.4.3+dfsg-9
- 8.4.3+dfsg-12
- 8.5.8+dfsg-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby-devise Ubuntu:18.04:LTS
- Softwareversionen
- 4.2.0-1
- 4.3.0-1
- 4.4.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby-devise Ubuntu:20.04:LTS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.5.0-3
Auf 4.5.0-3 aktualisieren